Jump to content

BLVCKSHVDE

Player
  • Posts

    3
  • Joined

  • Last visited

Reputation

0 Neutral

About BLVCKSHVDE

  • Rank
    Newbie
    Newbie
  1. Okay, so every addon I downloaded from curseforge for 4.5.8 shows 'out of date' on the addons window on char select.
  2. Cool, let me have a look at it. I think the version I downloaded for ATSW was for 5.3. I don't understand what checking load out means. So there's a list of different versions on curseforge? Thanks for the reply.
  3. Fairly new to this server, been looking for addons compatible with Tauri's MOP server. Websites such as legacy-wow are amazing, however, I cannot find a version compatible with Tauri server for Routes and Advanced Trade Skill Window. Anyone happens to know a version that works? I've downloaded a few, but they're all tagged as 'out of date'. Would greatly appreciate it if anyone knows. Thanks.
×
×
  • Create New...